Jump to content

Wifi card woes...


smithyandco
 Share

Recommended Posts

With new internet, in new house.... I deciding we'd go down the wireless route this time.

Virgin had provided us with an 'N' D-Link router and a 'N' USB Wifi Adaptor...

 

The D-Link USB adaptor managed 270Mbps in the same room as the router and the bedroom directly about the router but only 1-27Mbps in the office.

 

So I replaced the USB Adaptor with a PCI one... This one: http://www.edimax.co.uk/en/produce_detail....1&pl2_id=44

 

I wanted a TP-Link PCI card as I've used them on PCs for other people and they work great within Windows XP->7... The local nerd shop had none in stock (CCL Online) so I was lumped with this being the next option.

 

The PCI card has installed OK physically.

Windows XP recognised it as a "Network Device" but didn't have drivers (worth a shot...) - Then asked if it could connect to the internet to obtain drivers (yeah... funny).

 

So I installed the drivers which came with... Well I say that, the drivers are only available if you install the 3rd party Wireless manager application provided.

(I've search through the CD and internet downloaded, updated drivers high and low and not found the drivers on their own).

 

Now the drivers appear to be working... The device appears in 'Network Connections' in Control Panel.

 

I am able to establish a "connection" to my router using the 3rd party software and the built-in Windows software(if you disable the 3rd party shite) - In both situations the router successfully hands out an IP address to the PC in question via DHCP (192.168.0.100 - Gateway = 192.168.0.1).

 

However, once "connected" I cannot ping any device on the network nor can I connect to any device on the network or make a connection to the internet.

 

I have double checked the network Key is correct (if fact it refuses to connect if I get it wrong on purpose)... I have set the router to WEP instead of WPA2(which the new card states it supports), I have tried unsecured, tried setting the card to run at B/G speeds (54Mbps max) and even set the router to run at B/G speeds.... Still nothing.

 

If I attach the D-Link USB adaptor, I do not have these issues and can connect to the internet and other devices fine... Just 50x slower than the internet connection... :(

 

Sounds like a faulty card to me??

Or have I missed something...?

Link to comment
Share on other sites

sounds firewalled. Try disabling any security software.

 

Are there any chances of IP conflicts? try forcing a different IP.

On this PC (the one with the card) I only use the Windows Firewall and MSE... have disabled both with no joy.

 

At the moment, this is the only device on the network (other than the router & modem). But I attempted another IP by setting IP settings manually rather than using DHCP... still no joy. :(

 

Thanks for the suggestions though! :thumb:

Link to comment
Share on other sites

Hm, sounded like it could be a network authentication issue, there are reports of it doing the same thing under ubuntu with mixed networks.

 

To help narrow down the problems (ie removing the PC and its settings as the source of any issues) try downloading and booting up a ubuntu live CD/pen drive. Says it should run right out of the box here, and if it connects and is stable, then its likely a windows setting/windows driver issue. If it doesnt, then you know the issue is elsewhere.

Link to comment
Share on other sites

thanks caled, i'lll try a ubuntu live cd tomorrow.

 

in the meantime... i've connected the card to my phone via WiFi (WiFi router application) and that worked perfected.

but that's ad-hoc.

 

so i tried our old 'N' ADSL router and that worked perfectly (obviously no internet as we have cable) i was able to ping that router fine.

 

now it sounds like the router at fault.

Link to comment
Share on other sites

May or may not have cracked it... :blink:

 

I took the PC downstairs into the living room (same room as the router) and everything is perfect!

 

Back into the office/spare room and we're back to square one.

 

However, I noticed something... The PC was sending many packets out onto the wireless network fine (5000+) but only receiving a few (20-30).

 

The only thing I could think of is that either the router wasn't powerful enough to send a decent, reliable signal upstairs to the office but able to receive signals from the PCI card or that there is something causing interference in the outer walls of the house (where the rear of the PC is 5-10cm away from).

By bringing the PC away from the wall and off the computer desk onto the floor I am able to get a pretty solid connection.

 

The reason I expect interference is because we cannot get a TV signal via the aerial in the loft unless you take all the coax away from the outer wall. If you use an Amplified indoor aerial (on-top-tv jobbie) you can only get a signal if the aerial is away from the wall of the house.

 

As the house is fairly old, it could be safe to bet that the cause is either dodgy, old household wiring which needs updating or a crap router and coincidentally a crap TV reception at the front of the house (which happens to face the local TV mast...).

 

I'm confused... X(

Edited by smithyandco
Link to comment
Share on other sites

Try changing the channel on the router, 6-7 can usually get pretty flooded.

I've done that since posting the above... had no effect! :(

 

Thanks for suggesting it though... Might start looking into a new router (if Virgin won't give me one of these all-in-ones they give out with 100mb - Which is available in my area, but not worth going for yet as my 50mb line isn't stable).

Link to comment
Share on other sites

Do you have any TV signal sending equipment? Ie multiroom type stuff?

No, the only thing that could interfere is the cordless landline... Although the problem is still present with that turned off and the batteries ripped out of the handset.

 

I think I need a better router... recommendation would be smashing! :pancake:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...