Jump to content

Where to get injectors


taz500
 Share

Recommended Posts

What kind of injectors?

 

And what do you mean by 'best'? Easiest? Cheapest?

 

Sorry, Fuel injectors, is there such a thing as best easiest and cheapest all in one :rolleyes: i dont want some that are not going to last or are not upto the job. So i have no idea how much they are and fleebay has a wide range of prices and who do i trust on there. Any advice is greatly received.

Link to comment
Share on other sites

Do you mean standard injectors? If so then you need to choose the ones that match the ECU you intend to run.

 

Perhaps a bit more background about what you're trying to do might avoid you buying the wrong stuff in the near future.

Link to comment
Share on other sites

Do you mean standard injectors? If so then you need to choose the ones that match the ECU you intend to run.

 

Perhaps a bit more background about what you're trying to do might avoid you buying the wrong stuff in the near future.

 

Its a mk6 escort with a 2litre standard silvertop in with a DESK ecu in, im having problems with the running which happened very suddenly. It was stuttering very badly and kept cutting out but the power was missing and was not revving properly, i had more power with 3 quaters throttle and next to nothing on part or full throttle, i put it down to crap getting sucked up because i had let the petrol run low. The next day she would not start, turned out it was not sparking, i was told that if something is wrong with the fuel pressure or injectors then it would not spark. My otherhalfs brother and his mate that did the conversion and have done 6 so far changed the injectors with somemore they had and it fired up straight away. The problem being is they are second hand and although it fired up it still stuttered and stalled and would sometimes not start again, again not sparking. Now while trying alot of things we wiggled the loom to the injectors while it was running and it cut out, haha we thought here is the problem, so we sourced another and it has never stalled or not fired up since. But it still stutters especially when cold and i still dont have full power and still feels dead at full throttle, now the other possability is the fuel pump, which as i understand is expensive. I would like to try the injectors first but i dont want to waste money on them when it could be the pump and vice versa, im not getting much help from the otherhalfs brother or friend on this matter as its not there car and does not really affect them.

Thanks for your replys. J :thumb:

Link to comment
Share on other sites

To be honest it sounds like a case of typical bodged install (eg wiring loom problems) and of unknown parts.

 

I honestly couldn't say what its 'likely' to be. Could be anything involved with the conversion.

 

Injectors can go wrong, but its very rare. I dont think i've ever seen a zetec injector fail.

 

 

The comment about it not sparking due to fuel problems is complete rubbish.

Link to comment
Share on other sites

To be honest it sounds like a case of typical bodged install (eg wiring loom problems) and of unknown parts.

 

I honestly couldn't say what its 'likely' to be. Could be anything involved with the conversion.

 

Injectors can go wrong, but its very rare. I dont think i've ever seen a zetec injector fail.

 

 

The comment about it not sparking due to fuel problems is complete rubbish.

I would not say a bodged install as it has been running fault free for over a year, if its not likely to be injectors then im at a loss and might aswel scrap it

Link to comment
Share on other sites

My bodged install I mean something that isn't going to last and be reliable, which is what you appear to be suffering.

 

The loom that was found to be faulty, was that in the engine bay or inside the car (Eg where you modify it for the DESK ecu?)..

 

You said you tried some other injectors and the problem didn't go away, so it's unlikely to be those.

 

 

That said, this then falls under the same old set of faults which can all cause such issues:-

 

HT Leads

Plugs

MAF

CTS

TPS

Fuel filter/pump

Wiring

Air leak

Edited by Stu
Link to comment
Share on other sites

My bodged install I mean something that isn't going to last and be reliable, which is what you appear to be suffering.

 

The loom that was found to be faulty, was that in the engine bay or inside the car (Eg where you modify it for the DESK ecu?)..

 

You said you tried some other injectors and the problem didn't go away, so it's unlikely to be those.

 

 

That said, this then falls under the same old set of faults which can all cause such issues:-

 

HT Leads

Plugs

MAF

CTS

TPS

Fuel filter/pump

Wiring

Air leak

The bit of loom was under the bonnet that plugs onto the injectors, we changed the ecu and coil pack and leads and the fuel filter, i will try and check the others later.

Thanks for the reply

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...