Jump to content

Cabby roof problem


Recommended Posts

I got up this morning and as it was a nice day I thought I'd take the family out for a spin. I turned the ignition to 1 and pressed the powered roof switch and ...you've guessed it, nothing happened. I checked the motor in the boot to see if anything looked untoward but everything seemed fine. I turned the manual thingy on the motor from 90 to 180 degrees and opened the roof manually. Tried to close the roof by using the switch and it worked. I then tried to open it using the switch but nothing again. Any ideas out there?? It was fine last night.
Link to comment
Share on other sites

perhaps the motor is nackred has it got enoughfluid in it ???

Thanks for your reply. Yes, the fluid level is fine. I'd say the motor was knackered if there was no roof movement at all. As I said, it will close by power. There was no sign of any farting about previously with the motor. Haynes manual is a bit naff for this one. I will probably check the rams tomorrow. They're a bit of a shitter to get to though by the looks of it (removal of rear seats etc - hassle!)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...