Jump to content

switch problem maybe?? fao stu please.......


lightningescort1
 Share

Recommended Posts

right , hopefully stu can help me with this but anyone else is appreciated. got my car back on the road, and everything was hunky dorey , til about a week and a half ago, when the lights on the dash sometimes refused to come on. headlight were staying on so sat in the driver seat i assumed it was dash leds. they kept doing thi for a few days then one night on the way home from work a lorry behind me was flashing at me to warn me that my rear lights werent on either. i pulled over and messed about with the switch on and off a few times until they came on. now they dont come on at all and the headlights are fine. i have checked the fuses and wiring but nothing wrong there, i have even swapped the relay under the headlight switch for one i know is good, but nothing. could this be the switch ?? i have lost dash lights all rear lights except for reverse and the door open chime doesnt work anmore either . any help would be greatly appreciated, thanks in advance, jay .

 

i also have no light up ford badge now either but that is linked upto the passenger side headlight. i have also unplugged that to see if that was the problem but it would appear not :S

Link to comment
Share on other sites

right , hopefully stu can help me with this but anyone else is appreciated. got my car back on the road, and everything was hunky dorey , til about a week and a half ago, when the lights on the dash sometimes refused to come on. headlight were staying on so sat in the driver seat i assumed it was dash leds. they kept doing thi for a few days then one night on the way home from work a lorry behind me was flashing at me to warn me that my rear lights werent on either. i pulled over and messed about with the switch on and off a few times until they came on. now they dont come on at all and the headlights are fine. i have checked the fuses and wiring but nothing wrong there, i have even swapped the relay under the headlight switch for one i know is good, but nothing. could this be the switch ?? i have lost dash lights all rear lights except for reverse and the door open chime doesnt work anmore either . any help would be greatly appreciated, thanks in advance, jay .

 

i also have no light up ford badge now either but that is linked upto the passenger side headlight. i have also unplugged that to see if that was the problem but it would appear not :S

 

erm is there any reason you havnt suspected the obvious yet?

 

stalks??

Link to comment
Share on other sites

i bet if you hit the end of the switch the lights will come on. as said befor its the stalks

http://cgi.ebay.co.uk/FORD-ESCORT-dip-ligh...les_CarParts_SM

they sell them on there £23.95 plus £5.30 post

 

yeathats what i was doin mate and it was coming on, but didnt wanna waste cash on stalks if it could be something else. everything else worked from the stalks ya see. cheers mate

 

Aye, stalks would be my first bet.

 

first thing i thought aside from fuses/wiring etc. just thought id get your opinion first, cash is tight at mo , lol. cheers though stu.

 

 

right , hopefully stu can help me with this but anyone else is appreciated. got my car back on the road, and everything was hunky dorey , til about a week and a half ago, when the lights on the dash sometimes refused to come on. headlight were staying on so sat in the driver seat i assumed it was dash leds. they kept doing thi for a few days then one night on the way home from work a lorry behind me was flashing at me to warn me that my rear lights werent on either. i pulled over and messed about with the switch on and off a few times until they came on. now they dont come on at all and the headlights are fine. i have checked the fuses and wiring but nothing wrong there, i have even swapped the relay under the headlight switch for one i know is good, but nothing. could this be the switch ?? i have lost dash lights all rear lights except for reverse and the door open chime doesnt work anmore either . any help would be greatly appreciated, thanks in advance, jay .

 

i also have no light up ford badge now either but that is linked upto the passenger side headlight. i have also unplugged that to see if that was the problem but it would appear not :S

 

erm is there any reason you havnt suspected the obvious yet?

 

stalks??

 

switch , stalks , same thing right lol ??? this was the question . cheers .

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...